Lib/transaction/simple.rb:46: warning: already initialized constant Messages

From Kolmisoft Wiki

Jump to: navigation, search

Apache does not work, log shows:

[Fri May 23 03:50:30 2008] [warn] mod_fcgid: stderr: /usr/lib/ruby/gems/1.8/gems/transaction-simple-1.4.0/lib/transaction/simple.rb:46: warning: already initial ized constant Messages [Fri May 23 03:50:30 2008] [warn] mod_fcgid: stderr: /usr/lib/ruby/gems/1.8/gems/transaction-simple-1.4.0/lib/transaction/simple.rb:53: warning: already initial ized constant TRANSACTION_SIMPLE_VERSION [Fri May 23 03:50:30 2008] [warn] mod_fcgid: stderr: /usr/lib/ruby/gems/1.8/gems/transaction-simple-1.4.0/lib/transaction/simple.rb:436: warning: already initia lized constant SKIP_TRANSACTION_VARS [Fri May 23 03:50:36 2008] [warn] mod_fcgid: stderr: /usr/lib/ruby/gems/1.8/gems/transaction-simple-1.4.0/lib/transaction/simple.rb:46: warning: already initial ized constant Messages [Fri May 23 03:50:36 2008] [warn] mod_fcgid: stderr: /usr/lib/ruby/gems/1.8/gems/transaction-simple-1.4.0/lib/transaction/simple.rb:53: warning: already initial ized constant TRANSACTION_SIMPLE_VERSION [Fri May 23 03:50:36 2008] [warn] mod_fcgid: stderr: /usr/lib/ruby/gems/1.8/gems/transaction-simple-1.4.0/lib/transaction/simple.rb:436: warning: already initia lized constant SKIP_TRANSACTION_VARS [Fri May 23 03:50:39 2008] [warn] mod_fcgid: stderr: /usr/lib/ruby/gems/1.8/gems/transaction-simple-1.4.0/lib/transaction/simple.rb:46: warning: already initial ized constant Messages [Fri May 23 03:50:39 2008] [warn] mod_fcgid: stderr: /usr/lib/ruby/gems/1.8/gems/transaction-simple-1.4.0/lib/transaction/simple.rb:53: warning: already initial ized constant TRANSACTION_SIMPLE_VERSION [Fri May 23 03:50:39 2008] [warn] mod_fcgid: stderr: /usr/lib/ruby/gems/1.8/gems/transaction-simple-1.4.0/lib/transaction/simple.rb:436: warning: already initia lized constant SKIP_TRANSACTION_VARS

Solution:

gem install mysql -- --with-mysql-config=/usr/bin/mysql_config --no-rdoc --no-ri
gem install pdf-writer -y --no-rdoc --no-ri
gem install builder -y --no-rdoc --no-ri

Restart apache

Personal tools

Try MOR

Try M2