Call hangs after 30 seconds

From Kolmisoft Wiki

Jump to: navigation, search
  • Check timeout - maybe call can't last more then 30s?
  • Make sure call is made over SIP protocol
  • Write down all IPs of all devices which participate in the session
  • Enable sip debug (only for parties in the call, not global sip debug)
  • Check if you are using eyebeam or x-lite softphones
  • Check if provider uses SIP-I protocol (not supported by MOR/M2) (BT uses it - need separate hardware for SIP-I<->SIP interconnection)

It can be detected by checking SDP information for non standard attributes, or if audio codecs are not in use:

c=IN IP4 11.22.11.11
t=0 0
m=audio 33780 RTP/AVP 18 101
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-15
a=fmtp:18 annexb=no
a=ptime:20
a=X-vrzcap:vbd Ver=0 Mode=FaxPr ModemRtpRed=0
a=X-vrzcap:identification bin=DSR2871 Prot=mgcp App=MG






  • Disable firewall and try to make a call - if it works - check for firewall rules which block one of the IPs of the call ends.
  • Look for BYE packet, who is sending it.
  • If there is no BYE packet - big chance that problem is in the network - e.g. BYE packet does not reach our end or other end has problems with SIP protocol implementation
    • Check IP in SIP debug and compare to real IPs
    • If it is possible - try to capture SIP debug at the other end and compare to SIP debug in MOR






If during the call you see similar line:

[Aug 13 14:19:34] NOTICE[15712]: chan_sip.c:15683 sip_poke_noanswer: Peer '148' is now UNREACHABLE!  Last qualify: 0 

That means that device become unreachable and connection lost. It should point to network problems.







Such lines:

[Aug  6 11:50:43] NOTICE[22403]: chan_sip.c:2927 auto_congest: Auto-congesting SIP/prov253-0a1966d0
-- SIP/prov253-0a1966d0 is circuit-busy 
Scheduling destruction of SIP dialog '0ceffd014862f2c043209aa56d4930f4@82.194.82.123' in 32000 ms (Method: INVITE)

Clearly points that there is no response from dialed server, so timeout occurred.

Possible solutions:

  • Check IP/port settings in configuration
  • Check network settings (bad routing/bad settings/etc)
  • Change device at the other end






Eyebeam and X-Lite softphones tend to cut the call if no RTCP packet is received in 30 seconds.
For that open the Options menu, choose Advanced and check the Network settings.
Disable call Inactivity settings.

Image:Xlite.png




See also:

Image:sip_call_flow.png


[edit] See also

Personal tools

Try MOR

Try M2